Documentation Center
AlienVault® USM Appliance™

Known Issue: Upgrade to USM Appliance Version 5.4 Fails Due to CPU Lacking SSSE3

Reported Version: All versions prior to 5.4
Fixed Version 5.4.3
Deployment: All deployments
AlienVault Ticket ID ENG-105785

Description

In USM Appliance version 5.4, AlienVault updated its Network IDS to include the Hyperscan library, which requires the CPU to support the SSSE3 (Supplemental Streaming SIMD Extensions 3) instruction set. The upgrade process fails if the CPU hosting the virtual machine does not contain the SSSE3 instruction set.

Workaround

Please make sure the CPU contains the SSSE3 instruction set prior to running the update. See this Wikipedia page for a list of CPUs with SSSE3.

To check if the CPU contains SSSE3

  1. Connect to the AlienVault Console through SSH and use your credentials to log in.

    The AlienVault Setup menu displays.

  2. On the AlienVault Setup main menu, select Jailbreak System to gain command line access.

    Select Yes when prompted. You will be in the root directory.

  3. Type the following command:

    cat /proc/cpuinfo | grep ssse3

    If the result is empty, it means the CPU does not contain the SSSE3 instruction set, or that your virtual machine does not have access to it.

If the CPU contains the SSSE3 instruction set but the virtual machine does not have access to it, contact your virtual machine vendor for assistance.

If you have already started the update process and run into this issue, please contact AlienVault Technical Support.