• Support
  • Forums
  • Blogs

Nagios keeps loosing hosts after v5.5.1

ExpoE_SOCExpoE_SOC

New Life Form
Hello,

Has anyone been having issues with Nagios, after 5.5.1?

Some of our systems keep "loosing" hosts from the Nagios monitored list on both the GUI and /etc/nagios3/conf.d/ossim.../hosts folder.

They simply disapear after the following notification type:

"[1525078835] Warning: Check result queue contained results for host 'hostname1', but the host could not be
found!  Perhaps you forgot to define the host in your config files?
[1525078835] Warning: Check result queue contained results for host "hostname2', but the host could not be foun
d!  Perhaps you forgot to define the host in your config files?
[1525078835] Warning: Check result queue contained results for host 'hostname3', but the host could not be fou
nd!  Perhaps you forgot to define the host in your config files?
n
[1525078956] Caught SIGHUP, restarting
..."

Nothing appears in the debug file, just this warning.

Share post:

Answers

  • This issues is our nemesis.  I had a ticket escaleted to Development for this issue and it took a year and a half to fix.  As of a recent release, it's broken again!  We have another ticket, now escalated to Develpment again.  Only I hope it doesn't take another year and a half to fix.  We are setting AlienVault as a managed service. Out customers pay us for this.  We have SLA's.  And friggin AlienVault just randomly removes every single device out of availability monitoring.  

    AlienVault does some fantastic things.  But the lack of simple up/down monitoring makes us want to dump them from out MSSP all together.

    ExpoE_SOC
  • I solved the problem with a bit of old school linux-Fu, I basically made those host entries immutable.

    Go to the USM CLI

    go to the folder where all the hosts files for Nagios are stored:

    cd /etc/nagios3/conf.d/ossim-configs/hosts


    chattr +i *.cfg


    They can't be deleted untill they are non-immutable again (chattr -i *.cfg)

    Hope it helps.
Sign In or Register to comment.