• Support
  • Forums
  • Blogs

openvas stopped working after update!!

katherinqkatherinq

Entry Level
hi all

I have a problem with OSSIM and I is that after the update openvas have an error in the GUI displays the following:

Unable to connect to vulnerability scanner. If the system has been updated recently the vulnerability scanner is rebuilding its database. Please wait a few minutes.

when I try to start openvas-manager get the following:

 /etc/init.d/openvas-manager start
Starting OpenVAS Manager: Database disk image is malformed. Rebuilding...
/etc/init.d/openvas-manager: line 39: 13110 Aborted                 /usr/sbin/openvasmd --rebuild
openvasmd.

when I try to rebuild the database shows:

 openvasmd --rebuild
Aborted

could someone please guide me to solve this problem would greatly appreciate it! : D

Share post:

Answers

  • Any updates on this? Having the same problem...
  • Which problem are you having? Not able to connect to the vulnerability scanner or can't start OpenVas Manager? Which version of OSSIM are you running?
  • I've got the same problem, updating from 4.3 to 4.13. Don't know, if openvas was working in 4.3, but now it works for me. Solution is simple, first of all i've tried to reinstall openvas-manager, this was no help. Then i've found the database that reported to be corrupted, renamed it (you may delete, if you wish), rebuild database, start openvas manager.

    cd /var/lib/openvas/mgr && mv tasks.db tasks.db.old && openvasmd --rebuild && /etc/init.d/openvas-manager start

    Let it be here if someone else will stuck in this situation
Sign In or Register to comment.