• Support
  • Forums
  • Blogs

Is there a current bug/issue with using a csv to import Assets?

ei-alien-vaultei-alien-vault

New Life Form
+1
I attempted to bulk import assets from a csv but received the following error: "Headers not found". Anyone else come across this? 

Thanks,
Eric



Tagged:

Share post:

Answers

  • Does your csv have a header? This is what an export from assets looks like:









    "IPs";"hostname";"FQDNs";"Description";"Asset value";"Operating System";"Latitude";"Longitude";"Host ID";"External Asset";"Device Type"
    "192.168.100.70";"Host-192-168-100-70";"";"";"2";"";"";"";"06495482EBF149652E3152D9E44D0CB5";"0";""
    Please use the same header and format in your import file.
     
  • In my initial attempt before making the post, I used the export to see what I needed and created the csv as such. I still received the error stated above. Are the quotes e.t.c needed in the header as well as the other entries in the csv?

    Thanks,

    Eric
  • Yes, the quotes are needed. In terms of the data though, only the IP address is mandatory, but you still need to put in all the empty quotes. For example:

    "IPs";"hostname";"FQDNs";"Description";"Asset value";"Operating System";"Latitude";"Longitude";"Host ID";"External Asset";"Device Type"
    "1.2.3.4";"";"";"";"";"";"";"";"";"";""
  • I made an attempt but it failed. I actually did an export edited the IP address and tried to import the modified export file and it still failed.
  • What error did you get? The same "headers not found" error?
  • Yes the same error.
  • That's really strange. Can you email me your file so I can try it on my VM?
  • Don't use Excel as your CSV editor, it does strange things and I got the exact same error. Use notepad+ or another CSV editor. I also had luck creating the file in notepad, then changing the file extension to .csv, but you cannot open the file with excel, or it will be ruined.
  • The problem isn't what editor you use. The issue is that you need to make your "Comma Separated Values" separated by semi colons. Was having the same issue until I noticed the semi colons there instead of standard commas.
Sign In or Register to comment.